Just managed to break my installation, by doing a apt-get upgrade. I believe it has erased the module list so a quick 'cd /usr/src/xlinedevkit_arm/driver/' followed by a 'modprobe xline' fixed the problem this time.